BLTG Core Wallet 3.0.0 Mandatory Release 08/19/2019



  • BLTG Core version 3.0.0 is now available from: https://github.com/Block-Logic-Technology-Group/bltg/releases

    This is a new major version release, including various bug fixes and performance improvements, as well as updated translations.

    Please report bugs using the issue tracker at github: https://github.com/Block-Logic-Technology-Group/bltg/issues

    As Block-Logic is based on open-source code from the pivx project, an exhaustive description of all changes can be found at https://github.com/PIVX-Project/PIVX/releases

    Mandatory Update

    BLTG Core v3.0.0 is a mandatory update for all users.

    Masternodes will need to be restarted once both the masternode daemon and the controller wallet have been upgraded.

    How to Upgrade

    If you are running an older version, shut it down. Wait until it has completely shut down (which might take a few minutes for older versions), then run the installer (on Windows) or just copy over /Applications/BLTG-Qt (on Mac) or bltgd/bltg-qt (on Linux).

    Highlight changes

    • Port restriction removal
    • Performance improvements
    • Stability improvements
    • New statistical info RPC
    • Major GUI graphical updates

    bltg-cli masternode CLI not working? Several new commands were added in v2.3.1 to replace the two aforementioned commands, reference the Pivx v2.3.1 Release Notes for further details.


    Release Notes
    Please take the time to fully read the release notes: GitHub


    Download Link
    Download the appropriate wallet binary for your OS from the Github or Website
    For Self-compilers, please use "git checkout v3.0.0" to compile. (Not "master")


    How to Update
    As always, it is recommended to backup the existing wallet.dat file to a safe location before upgrading if you haven’t done so already via File -> Backup wallet and saving it in a different directory with a new name. If you use CLI/Linux, you can backup using the command

    ./bltg-cli backupwallet
    

    If your wallet is not running currently, you can back up the file "wallet.dat" from e.g. Start -> Run -> %APPDATA%\BLTG on Windows by making a copy elsewhere.

    1. Gracefully exit/stop the current wallet from the wallet. (File - Exit or ./bltg-cli stop)
    2. Download and install the new wallet appropriate for your OS.

    Linux/Rpi: Overwrite the existing executable files with the newly downloaded wallet binaries.
    Windows: Install via the setup executable file and run through the setup wizard to install.
    Mac OSX: Download .dmg file, open .dmg then drag BLTG icon to the applications folder icon. (copy over /Applications/BLTG-Qt)

    1. Re-start the wallet. (Launch from your BLTG shortcut icon or ./bltgd for linux)

    2. Once the wallet finishes syncing, ensure you are on the right network chain.

    3. Upgrade completed.

    P.S. If you are a masternode user, you must upgrade both the controller wallet & masternode wallet, then restart the masternode.


    CREDITS
    Thanks to everyone who directly contributed to this release.


Log in to reply